阔叶十大功劳果实:一个不错的艺术指标挺实用的【通达信】

来源:百度文库 编辑:九乡新闻网 时间:2022/09/27 22:17:20

一个不错的艺术指标挺实用的【通达信】

 


VAR22:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VAR33:=EMA(VAR22,10);
VAR44:=EMA(VAR33,10);
VAR55:=(3)*(VAR33)-(2)*(VAR44);
VAR66:=EMA(VAR55,5);
桥:(EMA(VAR66,1)),COLOR007700,LINETHICK1;
跨:=(REVERSE(桥)),COLORFFFFFF,LINETHICK1;
桥A:=IF(桥>REF(桥,1),桥,DRAWNULL);
DRAWBAND(桥,#007300,跨,#007300);
DRAWBAND(桥A,#8f2910,跨,#007300);
0,COLORFFFF00,LINETHICK2;
趋势:=(5)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(3)*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1))-SMA(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1),2,1);
底部:=5;
底:DRAWTEXT((CROSS(趋势,底部)),0,'◥◤'),COLOR00FFFF;
DRAWTEXT(CROSS((趋势),底部),15,'◢◣'),COLOR00FFFF;
VARA1:=((CLOSE>=REF(CLOSE,1)) AND(REF(CLOSE,1)>=REF(CLOSE,2)) AND(REF(CLOSE,1)<=REF(CLOSE,3)) AND(REF(CLOSE,2)<=REF(CLOSE,3)) AND((REF(CLOSE,4)>REF(CLOSE,2)) OR(REF(CLOSE,4)<=REF(CLOSE,2)) AND(REF(CLOSE,5)>=REF(CLOSE,3))) OR(CLOSE>=REF(CLOSE,1)) AND(REF(CLOSE,1)<=REF(CLOSE,2)) AND(CLOSE>=REF(CLOSE,2)) AND((REF(CLOSE,3)>REF(CLOSE,1)) OR(REF(CLOSE,3)<=REF(CLOSE,1)) AND(REF(CLOSE,4)>=REF(CLOSE,2))));
VARA2:=LLV(LOW,5);
VARA3:=HHV(HIGH,5);
VARA4:=EMA(((CLOSE-VARA2)/(VARA3-VARA2))*(100),4);
VARA5:=EMA((0.66699999)*(REF(VARA4,1))+(0.333)*(VARA4),2);
VARA6:=(VARA5<24) AND(OPEN
STICKLINE(VARA1 AND (VARA6),-40,40,2.5,1),COLOR2894FF;
VARB2:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VARB3:=EMA(VARB2,7);
VARB4:=EMA(VARB3,10);
VARB5:=(3)*(VARB3)-(2)*(VARB4);
VARB6:=EMA(VARB5,5);
探底2:IF((趋势<=5),-58,0),COLORFF00FF;
桥1:=EMA(VARB6,1);
美化:=IF(REF((COUNT((桥1<=REF(桥1,1)),5)=5),1) AND(桥1>REF(桥1,1)),10,0);
STICKLINE((美化),-20,20,3,1),COLORFFFF00;
{疯牛绝佳买点--真神了}
VARF1:=MA(HHV(HIGH,485),17);
VARF2:=MA(HHV(HIGH,222),17);
VARF3:=MA(HHV(HIGH,96),17);
VARF4:=MA(LLV(LOW,485),17);
VARF5:=MA(LLV(LOW,222),17);
VARF6:=MA(LLV(LOW,96),17);
VARF7:=MA((VARF4*0.96+VARF5*0.96+VARF6*0.96+VARF1*0.558+VARF2*0.558+VARF3*0.558)/6,17);
VARF8:=MA((VARF4*1.25+VARF5*1.23+VARF6*1.2+VARF1*0.55+VARF2*0.55+VARF3*0.65)/6,17);
VARF9:=MA((VARF4*1.3+VARF5*1.3+VARF6*1.3+VARF1*0.68+VARF2*0.68+VARF3*0.68)/6,17);
VARFA:=MA((VARF7*3+VARF8*2+VARF9)/6*1.738,17);
VARFB:=IF(C=C,VARFA,VARFA*DAY);VARFC:=LOW;
VARFD:=REF(LOW,1);VARFE:=SMA(ABS(VARFC-VARFD),3,1)/SMA(MAX(VARFC-VARFD,0),3,1)*100;
VARFF:=MA(IF(CLOSE*1.35<=VARFB,VARFE*10,VARFE/10),3);
VARF10:=LLV(LOW,30);VARF11:=HHV(VARFF,30);
绝佳买点:IF(C=C,MA(IF(LOW<=VARF10,(VARFF+VARF11*2)/2,0),3),DRAWNULL),COLOR00FFFF,NODRAW;
STICKLINE(绝佳买点,91,85,5,1),COLOR00FFFF;
I:=IF(CLOSE骤雨初晴:=ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);
DRAWICON(骤雨初晴>2.0000, 1.8000,17);
DRAWTEXT(CROSS(绝佳买点,2.4000) ,-8,'绝技'),COLORWHITE,LINETHICK1 ;
DRAWTEXT(CROSS(绝佳买点,4.2000) ,-20,'牛'),COLOR00FF00,LINETHICK1;
DRAWTEXT(CROSS(绝佳买点,1.20000) ,-32,'疯牛!'),COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(绝佳买点,2.40000) ,-45,'疯牛1'),COLORFF99FF,LINETHICK3;
DRAWTEXT(CROSS(绝佳买点,3.60000),38,'疯牛2'),COLORFF00FF,LINETHICK4;
DRAWTEXT(CROSS(绝佳买点,4.50000),58,'砸锅卖铁买'),COLOR9966FF,LINETHICK5;
DRAWTEXT(CROSS(绝佳买点,7.00000) ,78,'疯牛3'),COLORRED,LINETHICK4;
LJ1:=(C-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
LJ2:=(C-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
LJ3:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
LJF1:=SMA(LJ1,13,8);
LJF2:=(EMA(LJ2,3)),COLORFF22FF,LINETHICK2;
LJF3:=LJ3+100;
RSV1:=EMA(100*(C-LLV(LOW,18))/(HHV(H,18)-LLV(LOW,18)),3);
主A:=EMA(RSV1,3),COLOR208FFF,LINETHICK1;
DRAWTEXT(ISLASTBAR ANDLJF2>REF(LJF2,1),LJF2,'▲'),COLORFF00FF;
DRAWTEXT(ISLASTBAR ANDLJF2106,COLORFFFFFF;
STICKLINE(LJF3>80,102,99,1.5,0) ,COLOR00FF00;
STICKLINE(LJF1>86,104,102,1.5,0) ,COLOR00FFFF;
STICKLINE(LJF2>80,106,104,1.5,0) ,COLOR0000FF;
STICKLINE(主A>87,99,95,1.5,0) ,COLORFF0000;