铂爵婚纱怎么样:整合大盘和个股信息的VOL公式(副图,源码,附图)

来源:百度文库 编辑:九乡新闻网 时间:2024/02/21 10:47:37
下面的成交量公式,图片本身和系统的VOL一模一样,但做了些变动:

1. 去掉了5日、10日量显示(我觉得一眼就能看出金叉、死叉)
2. 增加了上证昨日的成交金额,单位是亿,以及今日的预计成交额,以及今日预计额除以昨日成交额的比例,这个比例是实时变化的,刚开盘时,往往很高,后面会慢慢相对稳定
3. 即便有了第2条的比例,但我时常忘记看成交量,所以又加了文字注释,说明大盘的成交额变化情况
4. 增加了大盘KDJ/RSI超跌时的提示
5. 增加了个股今日成交量(请注意,这里是成交量,不是成交额)除以昨日的比例(和系统的量比不是一会事,这里仅是今天除昨天)

源码如下:

X:=CONST(DATE);
Y:=IF(DATE上证昨日额亿:REF("999999$AMOUNT",1)/100000000,NODRAW;
上证今日额亿:"999999$AMOUNT"/Y*240/100000000,NODRAW;
上证预计额比:"999999$AMOUNT"/Y*240/REF("999999$AMOUNT",1),NODRAW;
123456, COLORBLACK, NODRAW;
个股预计量万:VOL/Y*240/10000,NODRAW;
预计量比:VOL/Y*240/REF(VOL,1),COLORYELLOW,NODRAW;
总交易日:=BARSCOUNT(CLOSE);
STICKLINE((VOL/Y*240)=CONST(LLV(VOL,60)),CONST(HHV(VOL,70)),(VOL/Y*240),2,0),COLORYELLOW;
STICKLINE((VOL/Y*240)=CONST(LLV(VOL,总交易日)),CONST(HHV(VOL,70)),0,0.5,0),COLOR006432;
DRAWTEXT((VOL/Y*240)=CONST(LLV(VOL,60)) AND (VOL/Y*240)>CONST(LLV(VOL,总交易日)),CONST(HHV(VOL,70))*0.7,'量底'),COLORYELLOW;
DRAWTEXT((VOL/Y*240)=CONST(LLV(VOL,60)) AND (VOL/Y*240)=CONST(LLV(VOL,总交易日)),CONST(HHV(VOL,70))*0.7,'绝对量底'),COLORYELLOW;
NOTEXTVOLUME:VOL,VOLSTICK;
NOTEXTVOL5:MA(VOL,5);
NOTEXTVOL10:MA(VOL,10);
{上证成交额直观描述}
预计变化:=(上证预计额比-1)*100;
预计1:=CONST(IF(预计变化>=40,1,0));
预计2:=CONST(IF(预计变化>=30 AND 预计变化<40,1,0));
预计3:=CONST(IF(预计变化>=20 AND 预计变化<30,1,0));
预计4:=CONST(IF(预计变化>=10 AND 预计变化<20,1,0));
预计5:=CONST(IF(预计变化>=5 AND 预计变化<10,1,0));
预计6:=CONST(IF(ABS(预计变化)<5,1,0));
预计7:=CONST(IF(预计变化<=-5 AND 预计变化>-10,1,0));
预计8:=CONST(IF(预计变化<=-10 AND 预计变化>-20,1,0));
预计9:=CONST(IF(预计变化<=-20 AND 预计变化>-30,1,0));
预计10:=CONST(IF(预计变化<=-30 AND 预计变化>-40,1,0));
预计11:=CONST(IF(预计变化<=-40,1,0));
位置1:=PERIOD=5 AND CURRBARSCOUNT=34;
DRAWTEXT(预计1=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘猛烈放量40%以上'), COLORFF00FF;
DRAWTEXT(预计2=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘大幅放量30-40%'), COLORFF00FF;
DRAWTEXT(预计3=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘放量20-30%'), COLORFF00FF;
DRAWTEXT(预计4=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘放量10-20%'), COLORFF00FF;
DRAWTEXT(预计5=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘轻微放量5-10%'), COLORFF00FF;
DRAWTEXT(预计6=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘成交额小幅波动±5%'), COLORFF00FF;
DRAWTEXT(预计7=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘轻微缩量5-10%'), COLORFF00FF;
DRAWTEXT(预计8=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘缩量10-20%'), COLORFF00FF;
DRAWTEXT(预计9=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘缩量20-30%'), COLORFF00FF;
DRAWTEXT(预计10=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘大幅缩量30-40%'), COLORFF00FF;
DRAWTEXT(预计11=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘猛烈缩量40%以上'), COLORFF00FF;
{大盘KDJ,RSI超跌,牛熊市都能用}
上证J超跌:=CONST(IF("999999$KDJ.J"<=5,1,0));
上证R超跌:=CONST(IF("999999$RSI.RSI1"<=20,1,0));
DRAWTEXT(上证J超跌=1 AND 上证R超跌=0 AND CURRBARSCOUNT=15, CONST(HHV(NOTEXTVOLUME,70))*0.6, '上证KDJ超跌(小于5),有反弹预期');
DRAWTEXT(上证J超跌=0 AND 上证R超跌=1 AND CURRBARSCOUNT=15, CONST(HHV(NOTEXTVOLUME,70))*0.6, '上证RSI超跌(小于20),有反弹预期');
DRAWTEXT(上证J超跌=1 AND 上证R超跌=1 AND CURRBARSCOUNT=15, CONST(HHV(NOTEXTVOLUME,70))*0.6, '上证KDJ-RSI都超跌(小于5或20)');

 {
整合大盘和个股信息的VOL公式(副图,源码,附图) 通达信逃顶公式副图(源码)(附图) - 通达信公式 个股与大盘强弱对比源码公式: - 指标公式交流 金股格格主、副图及选股公式源码奉送(附图) 金股格格主、副图及选股公式源码奉送(附图qq ★金股格格主、副图及选股公式源码11奉送(附图)★歇贴篇1★ 通达信趋势公式-副图 源码缠中缠 通达信趋势公式01-副图 源码 量是第一 绝妙精伦的公式(副图 源码) - 通达信公式 ★总结反思、寻求进步★金股格格主、副图及选股公式源码奉送(附图)★歇贴篇★ - 股票公式 ... ★金股格格主、副图及选股公式源码奉1送(附图)★歇贴篇1★ 通达信黄金柱主图(源码)(附图) - 通达信公式 非常有用的指标公式——主力力道(源码 副图 贴图 用法) 有图有源码---真正赚钱的指标----资金指数(副图) - 指标公式及技术交流区 - 理想... 副图公式源码:{强势出击预警} 有图 黑马雷达--通达信副图公式(源码 贴图 用法 ) 突破回踩(副图)-指标公式源码 [通达信]通达信难得一见成交量副图源码公式 个股和大盘的走势规律 量比公式的源码和质疑 大智慧抄底王辅图公式源码附图 买点提醒公式(附图,源码,贴图) 美好的理想!〈春天的指标〉【四】(副图、源码、贴图) - 指标公式交流区 - 理想论坛 -... 横盘启动买点选股 ( 副图 无未来 附图 源码)