镀锌钢板烤漆:通信达公式

来源:百度文库 编辑:九乡新闻网 时间:2020/07/13 19:55:54

通信达公式

股票 2010-07-24 09:28:26 阅读62 评论0   字号: 订阅

通信达公式:

成交量:

VOLUME:VOL,VOLSTICK;
流通盘亿:CAPITAL/1000000,LINETHICK0;
日换手:SUM(VOL,1)*100/CAPITAL,COLORF0F000,LINETHICK0 ;
五日换手:SUM(VOL,5)*100/CAPITAL,COLORF0F000,LINETHICK0 ;
十三日换手:SUM(VOL,13)*100/CAPITAL,COLORF0F000,LINETHICK0 ;
三十四日换手:SUM(VOL,34)*100/CAPITAL,COLORF0F000,LINETHICK0 ;
当日量比:V/(REF(MA(V,5),1)/240*FROMOPEN),COLORYELLOW,NODRAW;
每股收益:FINANCE(33),LINETHICK0,COLORWHITE;
每股净资产:FINANCE(34),LINETHICK0,COLORWHITE;

 

 

机构K线:买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWICON(BU,L-0.1,1);
DRAWICON(SEL,H+0.1,2);
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(买线<卖线,CLOSE,OPEN,2,1),COLORGREEN;
小股民:EMA(CLOSE,5),COLORWHITE;
操盘:MA(CLOSE,9),COLORCYAN,LINETHICK2;
界点:MA(CLOSE,20),COLORMAGENTA;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
日:=150;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;

DRAWICON(CMA(C,10) AND REF(C,1)1.03 AND V/CAPITAL>0.03,L*0.97,9);


 主力线:N 1 100 5

A1:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
A2:=SMA(A1,13,1);
A3:=SMA(A2,13,1);
出击:3*A2-2*A3,COLORYELLOW ,LINETHICK2;
阻力:3*A3-2*A2,COLORBLUE,LINETHICK2 ;
N:=10;
JE:=VOL/10;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
主买:=(QJ0*(JJ-MIN(CLOSE,OPEN)));
主卖:=(QJ0*(MIN(OPEN,CLOSE)-LOW));
散买:=(QJ0*(HIGH-MAX(OPEN,CLOSE)));
散卖:=(QJ0*(MAX(CLOSE,OPEN)-JJ));
庄净入:IF((主买-主卖)>0,主买-主卖,0)COLORRED,NODRAW;
庄净出:IF((主买-主卖)<0,主买-主卖,0)COLORGREEN,NODRAW;
散净入:IF((散买-散卖)>0,散买-散卖,0)COLORMAGENTA,NODRAW;
散净出:IF((散买-散卖)<0,散买-散卖,0)COLORBLUE,NODRAW;

 

 

获利筹码:

套牢盘:(1- WINNER(C))*100,STICK,COLORFFFF00,LINETHICK4;
获利盘:WINNER(C)*100,STICK,COLORRED,LINETHICK4;
控盘筹码:(0.1-WINNER(C/1.1))*100,STICK,COLORFF00FF,LINETHICK4;
浮筹:(WINNER(C*1.1)-WINNER(C*0.9))*80,STICK,COLORBLUE,LINETHICK4;
筹码重心:(HHV(获利盘,13)+LLV(获利盘,13))/2,COLORYELLOW,LINETHICK3;

 

 

资金流向:

ZC_1:=IF(LDYNAINFO(7),DYNAINFO(7)-(DYNAINFO(7)-H+0.02)/(H-L+0.02),0));
ZC_2:=DMA(ZC_1,V/CAPITAL)*100;
出货:=IF(ZC_2>0 AND ZC_2>REF(ZC_2,1),ZC_2/20,0);
轴:0,COLOR00FF00;
PJJ:=DMA((H + L + C * 2) / 4,0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=VOL / ((H - L) * 2 - ABS(C - O));
XVL:=IF(C > O,QJJ * (H - L),IF(C < O,QJJ * (H - O + (C - L)),VOL / 2)) + IF(C > O,0 - QJJ *

(H - C + (O - L)),IF(C < O,0 - QJJ * (H - L),0 - VOL / 2));
ZLL:=VOL / CAPITAL;
HSL1:=IF(ZLL > 10,10,ZLL);
HSL:=XVL / 20 / 1.15;
攻击流量:=HSL * 0.55 + REF(HSL,1) * 0.33 + REF(HSL,2) * 0.22;
GJJ:=EMA(攻击流量,8);
LLJX:=EMA(攻击流量,3);
流量:LLJX,COLORC875B7,COLORRED,NODRAW;
STICKLINE(流量 > 0,流量,0,2.3,0)COLOR0000FF;
STICKLINE(流量 < 0,流量,0,2.3,0),COLORFF4242;

STICKLINE(HSL * 0.4 >= 0,HSL * 0.4 * 1.5,0,0,1)COLORYELLOW;
STICKLINE(HSL * 0.4 < 0,HSL * 0.4 * 1.5,0,0,1)COLORGREEN;
ZJLL:=REF(LLJX,1);
QZJJ:=(((LLJX - ZJLL) / ZJLL) * 100);
流量幅%:IF(((LLJX > 0) AND (ZJLL < 0)),ABS(QZJJ),IF((((LLJX < 0) AND (ZJLL < 0)) AND (LLJX
< ZJLL)),(0 - QZJJ),QZJJ))COLORMAGENTA,NODRAW;
力度:HSL / 1000,COLOR9B37FF,COLORRED,NODRAW;
VARQ1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VARQ2:=SMA(ABS(LOW-VARQ1),13,1)/SMA(MAX(LOW-VARQ1,0),10,1);
VARQ3:=EMA(VARQ2,10);
VARQ4:=LLV(LOW,33);
VARQ5:=EMA(IF(LOW<=VARQ4,VARQ3,0),34)*100;
主力进场:STICKLINE(VARQ5>REF(VARQ5,1) AND 出货<=0,0,VARQ5,7,0 ),COLOR00FFFF;

 

 

主力筹码进来:N 1 100 5

活筹:=100*WINNER(REF(CLOSE,1)*1.1)-100*WINNER(REF(CLOSE,1)*0.9);
死筹:=100*WINNER(CLOSE);
主力筹码:100*WINNER(CLOSE*0.95),LINETHICK1;
主力持仓:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),LINETHICK0;
获利3:=100*WINNER(CLOSE*0.97);
获利20:=100*WINNER(CLOSE*0.9*0.9);
获利30:=100*WINNER(CLOSE*0.9*0.9*0.9);
穿透筹码:=100*WINNER(CLOSE)-100*WINNER(REF(CLOSE,1)*1);
QW:LOWCOST(4),COLOR888888,LINETHICK0;
买点:IF(QW=1,30,0),COLOR0000FF,LINETHICK3;
STICKLINE(获利3>85,0,获利3,4,0),COLORYELLOW;
STICKLINE(获利30>20,0,获利30,2,1),COLORWHITE;
STICKLINE(主力筹码>30,0,主力筹码,2,1),COLORFF00FF;
STICKLINE(获利20>20,0,获利20,3,1),COLOR00FF00;
VAR31:=1;
VAR32:=1/WINNER(CLOSE);
VAR33:=MA(CLOSE,13);
VAR34:=100-ABS((CLOSE-VAR33)/VAR33*100);
Z:(200-IF(VAR32>5,IF(VAR32<100,VAR32,VAR34-10),0))*VAR31,COLORGREEN,LINETHICK0,POINTDOT ;
新庄:Z,COLORC0C0C0;
STICKLINE(1,Z,200,8,0),COLORGREEN;

 

 

 

资金进出:

ZLCM:=EMA(WINNER(CLOSE)*70,3);SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);ZZLKP:=ZLCM/(ZLCM+SHCM)*100;ZZLJJ:=EMA(ZZLKP,89);ZJLRQD:=ZZLKP-ZZLJJ;AA:=EMA(ZJLRQD,3);BB:=EMA(AA,5);CC:=AA-BB;STICKLINE(CCREF(CC,2),CC,0,1,1), COLORRED;资金进场:IF(CROSS(AA,BB),3,0),STICK,LINETHICK3,COLORFF00FF;资金出场:IF(CROSS(BB,AA),-3,0),STICK,LINETHICK3,COLOR00FF00;DRAWICON(资金进场>0,4,1);DRAWICON(资金出场<0,-4,2);

VAR1:=AMOUNT/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

流入亿:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE

流出亿:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE

额亿:流入亿+流出亿,COLORFFFF00,NODRAW;

五日额亿:SUM(额亿,5)COLORF00FF0,LINETHICK0 ;
二十四日额亿:SUM(额亿,24)COLORF00FF0,LINETHICK0 ;
四十日额亿:SUM(额亿,40)COLORF00FF0,LINETHICK0 ;

 

 

筹码分布:

价量:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)
,COLOR00CCFF,NODRAW;
主线:(((价量-LLV(价量,27))/(HHV(价量,27)-LLV(价量,27)))*(4))*(25)
,COLORCYAN,NODRAW;
快线:(((价量-LLV(价量,9))/(HHV(价量,9)-LLV(价量,9)))*(4))*(25)
,COLOR55AAFF,NODRAW;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K1:=SMA(RSV,3,1);
D1:=SMA(K1,3,1);
KK:=INTPART(K1);
DD:=INTPART(D1);
TFXXS:=KK+DD;{变异KD风险系数}
TGLXS:=(TFXXS-REF(TFXXS,1));{变异KD乖离系数:资金流向}
{红}
STICKLINE(TGLXS>0 AND TGLXS>REF(TGLXS,1),100,TGLXS+100,2.5,0),COLOR0000AA;
STICKLINE(TGLXS>0 AND TGLXS>REF(TGLXS,1),100,TGLXS+100,1.5,0),COLOR0022CC;
STICKLINE(TGLXS>0 AND TGLXS>REF(TGLXS,1),100,TGLXS+100,0.5,0),COLOR0055FF;
{粉}
STICKLINE(TGLXS<0 AND TGLXS>REF(TGLXS,1),100,TGLXS+100,2.5,0),COLORAA00BB;
STICKLINE(TGLXS<0 AND TGLXS>REF(TGLXS,1),100,TGLXS+100,1.5,0),COLORCC22BB;
STICKLINE(TGLXS<0 AND TGLXS>REF(TGLXS,1),100,TGLXS+100,0.5,0),COLORFF55BB;
{黄}
STICKLINE(TGLXS>0 AND TGLXS<=REF(TGLXS,1),100,TGLXS+100,2.5,0),COLOR00AAFF;
STICKLINE(TGLXS>0 AND TGLXS<=REF(TGLXS,1),100,TGLXS+100,1.5,0),COLOR00CCFF;
STICKLINE(TGLXS>0 AND TGLXS<=REF(TGLXS,1),100,TGLXS+100,0.5,0),COLOR00FFFF;
{蓝}
STICKLINE(TGLXS<0 AND TGLXS<=REF(TGLXS,1),100,TGLXS+100,2.5,0),COLORFF7700;
STICKLINE(TGLXS<0 AND TGLXS<=REF(TGLXS,1),100,TGLXS+100,1.5,0),COLORFFAA22;
STICKLINE(TGLXS<0 AND TGLXS<=REF(TGLXS,1),100,TGLXS+100,0.5,0),COLORFFFF55;
STICKLINE(TGLXS=0 AND REF(TGLXS,1)>=0,100,TGLXS+100,8,0),COLORBROWN;
STICKLINE(TGLXS=0 AND REF(TGLXS,1)<0,100,TGLXS+100,8,0),COLORWHITE;
ZLCM:=EMA(WINNER(CLOSE)*70,3);{主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{散户套牢筹码系数}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{主力控盘筹码系数}
ZSHJJ:=EMA(ZSHTL,55);{散户警戒}
ZZLJJ:=EMA(ZZLKP,55);{主力警戒}
散兵坑:IF(ZZLKP<=10,ZZLKP,ZZLKP),COLORMAGENTA,NODRAW;
{散户套牢筹码}
STICKLINE(C>0,ZSHTL,ZZLKP,2,0),COLOR808080;
{散户筹码警戒}
STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,2,0),COLORC0C0C0;
{主力控盘筹码}
{粉}
STICKLINE(ZZLKP>REF(ZZLKP,1) AND ZZLKP>20,ZZLKP,20,2.5,0 ),COLORAA00BB;
STICKLINE(ZZLKP>REF(ZZLKP,1) AND ZZLKP>20,ZZLKP,20,1.5,0 ),COLORCC22BB;
STICKLINE(ZZLKP>REF(ZZLKP,1) AND ZZLKP>20,ZZLKP,20,0.5,0 ),COLOREE44BB;
{蓝}
STICKLINE(ZZLKP<=REF(ZZLKP,1) AND ZZLKP>20,ZZLKP,20,2.5,0 ),COLORFF7700;
STICKLINE(ZZLKP<=REF(ZZLKP,1) AND ZZLKP>20,ZZLKP,20,1.5,0 ),COLORFFAA22;
STICKLINE(ZZLKP<=REF(ZZLKP,1) AND ZZLKP>20,ZZLKP,20,0.5 ,0 ),COLORFFFF55;
{亮红}
STICKLINE(ZZLKP>REF(ZZLKP,1) AND ZZLKP<20,ZZLKP,0,2.5,0 ),COLOR131FFD;
STICKLINE(ZZLKP>REF(ZZLKP,1) AND ZZLKP<20,ZZLKP,0,1.5,0 ),COLOR5050FF;
STICKLINE(ZZLKP>REF(ZZLKP,1) AND ZZLKP<20,ZZLKP,0,0.5,0 ),COLOR7E7EFF;
{深蓝}
STICKLINE(ZZLKP<=REF(ZZLKP,1) AND ZZLKP<20,ZZLKP,0,2.5,0 ),COLORAA0000;
STICKLINE(ZZLKP<=REF(ZZLKP,1) AND ZZLKP<20,ZZLKP,0,1.5,0 ),COLORCC0000;
STICKLINE(ZZLKP<=REF(ZZLKP,1) AND ZZLKP<20,ZZLKP,0,0.5 ,0 ),COLORFF0000;
{主力筹码警戒}
{黄}
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,2.5,0 ),COLOR00AAFF;
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,1.5,0 ),COLOR00CCFF;
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,0.5,0 ),COLOR00FFFF;
{红}
STICKLINE(ZZLKP>ZZLJJ AND ZZLJJ>50,ZZLKP,ZZLJJ,2.5,0 ),COLOR0000AA;
STICKLINE(ZZLKP>ZZLJJ AND ZZLJJ>50,ZZLKP,ZZLJJ,1.5,0 ),COLOR0022CC;
STICKLINE(ZZLKP>ZZLJJ AND ZZLJJ>50,ZZLKP,ZZLJJ,0.5 ,0 ),COLOR0055FF;
{红}
STICKLINE(ZZLKP>ZZLJJ AND ZZLJJ<50 AND ZZLKP>50
AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,50,2.5,0 ),COLOR0000AA;
STICKLINE(ZZLKP>ZZLJJ AND ZZLJJ<50 AND ZZLKP>50
AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,50,1.5,0 ),COLOR0022CC;
STICKLINE(ZZLKP>ZZLJJ AND ZZLJJ<50 AND ZZLKP>50
AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,50,0.5 ,0 ),COLOR0055FF;
{铸顶风险区}
{绿}
STICKLINE(ZZLKP>80,ZZLKP,ZZLKP-(ZZLKP-80)/2,2.5,0),COLOR00AA00;
STICKLINE(ZZLKP>80,ZZLKP,ZZLKP-(ZZLKP-80)/2,1.5,0),COLOR00CC00;
STICKLINE(ZZLKP>80,ZZLKP,ZZLKP-(ZZLKP-80)/2,0.5,0),COLOR00FF00;
{散兵坑}
STICKLINE(ZZLKP<=10,ZZLKP,0,5,0),COLORDD00DD;
100,COLORGREEN;
80,COLORGREEN;
{0,COLORGREEN;}
{主线快线}
价量,COLOR0CC0FF,LINETHICK2;
主线,COLOR00FFAA,LINETHICK2;
快线,LINESTICK,COLORFF68DD;

 

 

大中散户:

换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
主力能量:(主力-均量)COLORRED,NODRAW;
大户量:(大户-均量)COLORMAGENTA,NODRAW;
中户量:(中户-均量)COLORYELLOW,NODRAW;
散户量:(散户-均量),NODRAW;
操盘:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORRED;
减仓:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1,0),COLOR00CC20;
反弹:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1,0),COLOR00CCCC;
寻底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORFF9900;
DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,4.2,4.8),'机构'),COLORRED;
操盘1:STICKLINE(大户量>=0 AND 大户量>=REF(大户量,1),3,3+大户量,1,0),COLORRED;
减仓1:STICKLINE(大户量>=0 AND 大户量< REF(大户量,1),3,3+大户量,1,0),COLOR00CC20;
反弹1:STICKLINE(大户量<0 AND 大户量>=REF(大户量,1),3,3+大户量,1,0),COLOR00CCCC;
寻底1:STICKLINE(大户量<0 AND 大户量< REF(大户量,1),3,3+大户量,1,0),COLORFF9900;
DRAWTEXT(ISLASTBAR=1,IF(大户量>=0,2.7,3.3),'大户'),COLORMAGENTA;
操盘2:STICKLINE(中户量>=0 AND 中户量>=REF(中户量,1),1.5,1.5+中户量,1,0),COLORRED;
减仓2:STICKLINE(中户量>=0 AND 中户量< REF(中户量,1),1.5,1.5+中户量,1,0),COLOR00CC20;
反弹2:STICKLINE(中户量<0 AND 中户量>=REF(中户量,1),1.5,1.5+中户量,1,0),COLOR00CCCC;
寻底2:STICKLINE(中户量<0 AND 中户量< REF(中户量,1),1.5,1.5+中户量,1,0),COLORFF9900;
DRAWTEXT(ISLASTBAR=1,IF(中户量>=0,1.2,1.8),'中户'),COLORYELLOW;
操盘3:STICKLINE(散户量>=0 AND 散户量>=REF(散户量,1),0,散户量,1,0),COLORRED;
减仓3:STICKLINE(散户量>=0 AND 散户量< REF(散户量,1),0,散户量,1,0),COLOR00CC20;
反弹3:STICKLINE(散户量<0 AND 散户量>=REF(散户量,1),0,散户量,1,0),COLOR00CCCC;
寻底3:STICKLINE(散户量<0 AND 散户量< REF(散户量,1),0,散户量,1,0),COLORFF9900;
DRAWTEXT(ISLASTBAR=1,IF(散户量>=0,-0.3,0.3),'散户'),COLORGREEN;
红买盘:MA(C,3),COLORRED,NODRAW;
绿卖盘:MA(C,3),COLORGREEN,NODRAW;
黄反弹:MA(C,3),COLORYELLOW,NODRAW;
蓝寻底:MA(C,3),COLORFF9900,NODRAW;
成交量:VOL,COLORWHITE,NODRAW;

B:=ZIG(3,50/5)*1;
G:=MA(B,2);
D:=CROSS(B,G)*10;
W:=CROSS(G,B)*10;
DRAWTEXT(W=10,4,'卖' ),COLORWHITE;
DRAWTEXT(D=10,4,'买'),COLORCYAN;

 

 

量能线:

CS:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100;
YJD: (EMA(CS,34)-20)*2;

 

筹码攻击: D 30  90 72

STICKLINE(C>0,300,400,100,0),COLOR002300;
STICKLINE(C>0,200,300,100,0),COLOR320000;
STICKLINE(C>0,100,200,100,0),COLOR320000;
STICKLINE(C>0,-5,100,100,0),COLOR002300;
HL10:WINNER(C/1.1)*100,STICK,COLOR0000FF;
HL20:WINNER(C/1.2)*100,STICK,COLOR00FFFF;
HL30:WINNER(C/1.3)*100,STICK,COLORFF00FF;
TL10:=(1-WINNER(C/0.9))*100;
TL20:=(1-WINNER(C/0.8))*100;
TL30:=(1-WINNER(C/0.7))*100;
STICKLINE(TL10>-10,400,400-TL10,1,0),COLORFFFF33;
STICKLINE(TL20>-10,400,400-TL20,1,0),COLORFF6600;
STICKLINE(TL30>-10,400,400-TL30,1,0),COLORCC0000;
CXH10:=(WINNER(C)-WINNER(C/1.1))*100;
CXH20:=(WINNER(C)-WINNER(C/1.2))*100;
CXH30:=(WINNER(C)-WINNER(C/1.3))*100;
STICKLINE(CXH30>-10,200,200-CXH30,1,0),COLOR99FFFF;
STICKLINE(CXH20>-10,200,200-CXH20,1,0),COLOR33CCFF;
STICKLINE(CXH10>-10,200,200-CXH10,1,0),COLOR0066FF;
CST10:=(WINNER(C/0.9)-WINNER(C))*100;
CST20:=(WINNER(C/0.8)-WINNER(C))*100;
CST30:=(WINNER(C/0.7)-WINNER(C))*100;
STICKLINE(CST30>-10,200,200+CST30,1,0),COLOR99FF66;
STICKLINE(CST20>-10,200,200+CST20,1,0),COLOR00FF33;
STICKLINE(CST10>-10,200,200+CST10,1,0),COLOR009900;
BB:100,POINTDOT,LINETHICK2,COLORRED;
AA:200,COLORYELLOW;
CC:300,POINTDOT,LINETHICK2,COLORGREEN;
套牢盘:(1- WINNER(C))*100,COLORF0F000,LINETHICK0 ;
获利盘:WINNER(C)*100,COLORF0F000,LINETHICK0 ;

 

筹码堆积:选择方式1  1111  1    时长 1 1111   120    换手次数  1    1111  2

DA1:=IF(130>TOTALBARSCOUNT,TOTALBARSCOUNT,130);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(LO*GZ) AND C1LH10:=SUM(IF(C1>=LO AND C1L1:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;
L2:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;
L3:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);
STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT,HI*99/100,HI/GZ,9,0)COLOR222211,LINETHICK3;
STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,1)*99/100,HI/POW(GZ,2),9,0)COLOR222211,LINETHICK3;
STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,2)*99/100,HI/POW(GZ,3),9,0)COLOR222211,LINETHICK3;
STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,3)*99/100,HI/POW(GZ,4),9,0)COLOR222211,LINETHICK3;
STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,4)*99/100,HI/POW(GZ,5),9,0)COLOR222211,LINETHICK3;
STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,5)*99/100,HI/POW(GZ,6),9,0)COLOR222211,LINETHICK3;
STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,6)*99/100,HI/POW(GZ,7),9,0)COLOR222211,LINETHICK3;
STICKLINE(CEILING(DA*L8/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,2),LO*POW(GZ,3)*99/100,9,0)COLOR222211,LINETHICK3;
STICKLINE(CEILING(DA*L9/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,1),LO*POW(GZ,2)*99/100,9,0)COLOR222211,LINETHICK3;
STICKLINE(CEILING(DA*L10/SS)*3>=CURRBARSCOUNT,LO,LO*POW(GZ,1)*99/100,9,0)COLOR222211,LINETHICK3;
DRAWKLINE(H,O,L,C);

 

 

大盘:

VARA:=INDEXO;
VARB:=INDEXC;
VARC:=INDEXH;
VARD:=INDEXL;
STICKLINE(VARB=VARA,VARC,VARD,0.2,1),COLORRED;
STICKLINE(VARB=VARA,VARA,VARB,3,1),COLORRED;
STICKLINE(VARB>VARA,VARA,VARB,3,1),COLORRED;
STICKLINE(VARBSTICKLINE(VARB>VARA,VARB,VARC,0,0.1),COLORRED;
STICKLINE(VARB>VARA,VARA,VARD,0,0.1),COLORRED;
STICKLINE(VARA>VARB,VARB,VARD,0,0.1),COLORCYAN;

 


买卖盘:

成交量:=VOL;
VAR1:=成交量/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘:(CLOSE>OPEN,VAR1*(HIGH-LOW),(CLOSE卖盘:(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),(CLOSESTICKLINE(买盘>卖盘,0,VAR1+买盘,3,0),COLOR000088;
STICKLINE(买盘>卖盘,0,VAR1+买盘,1.5,0),COLOR0000AA;
STICKLINE(买盘>卖盘,0,VAR1+买盘,1,0),COLOR0000CC;
STICKLINE(买盘>卖盘,0,VAR1+买盘,0.5,0),COLOR0000EE;
STICKLINE(卖盘>买盘,0,VAR1+买盘,3,0),COLOR008800;
STICKLINE(卖盘>买盘,0,VAR1+买盘,1.5,0),COLOR00AA00;
STICKLINE(卖盘>买盘,0,VAR1+买盘,1,0),COLOR00CC00;
STICKLINE(卖盘>买盘,0,VAR1+买盘,0.5,0),COLOR00EE00;
五日买:SUM(买盘,5),COLORF0F000,LINETHICK0 ;
五日卖:SUM(卖盘,5),COLOR00FF00,LINETHICK0 ;
十三日买:SUM(买盘,13),COLORF0F000,LINETHICK0 ;
十三日卖:SUM(卖盘,13),COLOR00FF00,LINETHICK0 ;
二十买:SUM(买盘,20),COLORF0F000,LINETHICK0 ;
二十卖:SUM(卖盘,20),COLOR00FF00,LINETHICK0 ;
三十四买:SUM(买盘,34),COLORF0F000,LINETHICK0 ;
三十四卖:SUM(卖盘,34),COLOR00FF00,LINETHICK0 ;

 

控盘:

VAR1:= EMA(EMA(CLOSE,13),13);
控盘指数: (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000,POINTDOT,COLORFFCCCC;
STICKLINE(控盘指数<0,控盘指数,0,2,0),COLORGRAY;
无庄控盘: 控盘指数<0,LINETHICK0,COLORGRAY;
STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>0 AND 控盘指数<3,控盘指数,0,2,1),COLORRED;
STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>0 AND 控盘指数>3,控盘指数,0,2,1),COLORRED;
STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>3,控盘指数,3,4,1),COLORFF00FF;
主力控盘: 控盘指数>REF(控盘指数,1) AND 控盘指数>0,LINETHICK0,COLORRED;
STICKLINE(控盘指数0,控盘指数,0,2,0),COLOR00FF00;
控盘减弱: 控盘指数0,LINETHICK0,COLOR00FF00;
VARA:= EMA(0.667*REF(控盘指数,1)+0.333*控盘指数,2);
STICKLINE(控盘指数>VARA,控盘指数,VARA,2,0),COLORRED;
B2:= 控盘指数>VARA;

B1:= (控盘指数>REF(控盘指数,1) AND 控盘指数>0)=1;
开始控盘: B1>REF(B1,1),COLORMAGENTA,LINETHICK3;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(X,13);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWICON(FILTER(买=1,5),L*0.11,1);
DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))*20,COLORWHITE,LINETHICK1;
DEA:EMA(DIFF,9),COLORYELLOW,LINETHICK1;
MACD:2*(DIFF-DEA), COLORSTICK;
MACD1:=2*(DIFF-DEA),COLORRED,NODRAW;
MACD2:=EMA(MACD1,3),LINETHICK1,COLOR00FF00,NODRAW;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLORYELLOW;
STICKLINE(MACD1S1:=MACD<0;
S2:= (MACD>=0);
S3:=BARSLAST(CROSS(DIFF,DEA));
S4:=REF(S3,S3+1);
S5:=DEA>REF(DEA,S4);
S6:=DEA;
上成立:=CROSS(DIFF,DEA) AND S5;
下成立:=CROSS(DIFF,DEA) AND S6;
L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
L2:=EMA(L1,9);
L3:=BARSLAST(CROSS(L1,L2));
L4:=REF(L3,L3+1);
L5:=L2;

 

 

 

小户:JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=AMOUNT/IF(HIGH=LOW,4,HIGH-LOW);
TD1:=QJ0*(MIN(OPEN,CLOSE)-LOW);DD1:=QJ0*(JJ-MIN(CLOSE,OPEN));
DD2:=QJ0*(HIGH-MAX(OPEN,CLOSE));TD2:=QJ0*(MAX(CLOSE,OPEN)-JJ);
TD:=TD1-TD2;DA:=DD1-DD2;XD1:=1-(TD1+DD1);XD2:=1-(TD2+DD2);
TZ:=V/SUM(V,60)*100;DT:=((XD1-XD2)/10000)/TZ;
小股民持仓:SUM(DT,22),COLOR888888,LINETHICK1;
STICKLINE(DT>0,小股民持仓,小股民持仓+DT,1,0),COLORFF00FF;
STICKLINE(DT<0,小股民持仓+DT,小股民持仓,1,0),COLORFF8800;

 

 

大户:

JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=AMOUNT/IF(HIGH=LOW,4,HIGH-LOW);
买1:=QJ0*(MIN(OPEN,CLOSE)-LOW);
买2:=QJ0*(JJ-MIN(CLOSE,OPEN));
卖1:=QJ0*(MAX(CLOSE,OPEN)-JJ);
卖2:=QJ0*(HIGH-MAX(OPEN,CLOSE));
DT:=((买1+买2)-(卖1+卖2))/10000;
主力持仓:SUM(DT,66),COLORWHITE,LINETHICK1;
STICKLINE(DT>0,主力持仓,主力持仓+DT,1,0),COLOR0000FF;
STICKLINE(DT<0,主力持仓+DT,主力持仓,1,0),COLOR00FF00;