郑州地铁12号线规划图:确保向下笔成立后的“底分型”选股公式源码(修改更新)

来源:百度文库 编辑:九乡新闻网 时间:2020/07/13 19:35:10
笔底分型”选股和预警公式源码。这个公式剔除了中继型顶分型后的底分型,确保向下笔成立后出现的底分型。同时处理了K线包含关系:底之前最多处理4个K线包含;底之后只能处理一个。比前面发的“底分型”选股减少了信号数。可以比较一下。

    我的理解:最好用在日线,然后看1F、或5F有没有出现买点。这样可能成功率高些。按分型操作,在T+1的情况下,很小级别好像不行。
    用这个公式今天只选出了一个:600372

    前一个公式选出了27个,其中26个属于中继情况。

    前面的发表的公式有错误,感谢网友的提醒。这次在四款软件上通过的测试,并进行选股,没有再发现有问题。下面的公式是大智慧L2用的。其他软件最后一句要更改,具体见公式尾部替换说明。请下载过的网友重新下载。对给您带来的不便,深表歉意!2009.4.28


{笔底分型 选股 预警 确保向下笔成立后的底分型}
V00:= HIGHV01:= HIGHREF(LOW,1);
V02:= HIGH>REF(HIGH,1) AND LOWV03:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
V04:= REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW
 AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);
V1:= COUNT(V00,6)>=3 AND COUNT(V01 OR V02,5)=0 AND LLVBARS(LOW,6) = 1 AND HHVBARS(HIGH,6) >= 5 AND V03;
V2:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 2 AND HHVBARS(HIGH,7) >= 6 AND V04;
V3:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 1 AND HHVBARS(HIGH,7) >= 6 AND V03;
V4:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 2 AND HHVBARS(HIGH,8) >= 7 AND V04;
V5:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 1 AND HHVBARS(HIGH,8) >= 7 AND V03;
V6:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 2 AND HHVBARS(HIGH,9) >= 8 AND V04;
V7:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 1 AND HHVBARS(HIGH,9) >= 8 AND V03;
V8:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 2 AND HHVBARS(HIGH,10) >= 9 AND V04;
V9:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 1 AND HHVBARS(HIGH,10) >= 9 AND V03;
V10:= COUNT(V00,11)>=3 AND COUNT(V01 OR V02,10)<=5 AND LLVBARS(LOW,11) = 2 AND HHVBARS(HIGH,11) >= 10 AND V04;
XG:CURRENTTIME>092530 AND (V1 OR V2 OR V3 OR V4 OR V5 OR V6 OR V7 OR V8 OR V9 OR V10)
 AND STRFIND(stkname,'ST',1)=0 AND STRFIND(stkname,'S',1)=0 AND DYNAINFO(4)<>0;

 

通达信:XG: V1 OR V2 OR V3 OR V4 OR V5 OR V6 OR V7 OR V8 OR V9 OR V10;

 

同花顺:XG: (V1 OR V2 OR V3 OR V4 OR V5 OR V6 OR V7 OR V8 OR V9 OR V10)
 AND STRFIND(stkname,'ST',1)=0 AND STRFIND(stkname,'S',1)=0 ;

 

飞狐:不用替换。

语句解释:

V00赋值: 最高价<昨日最高价 AND 最低价<昨日最低价
V01赋值: 最高价<昨日最高价 AND 最低价>昨日最低价
V02赋值: 最高价>昨日最高价 AND 最低价<昨日最低价
V03赋值: 最高价>昨日最高价 AND 最低价>昨日最低价
V04赋值: 2日前的最高价 < 最高价 AND 2日前的最低价 < 最低价 AND 2日前的最高价 > 昨日最高价 AND 2日前的最低价 < 昨日最低价
V1赋值: 统计6日中满足V00的天数>=3 AND 统计5日中满足V01ORV02的天数=0 AND 6日内最低价距今天数 = 1 AND 6日内最高价距今天数 >= 5 AND V03
V2赋值: 统计7日中满足V00的天数>=3 AND 统计6日中满足V01ORV02的天数=1 AND 7日内最低价距今天数 = 2 AND 7日内最高价距今天数 >= 6 AND V04
V3赋值: 统计7日中满足V00的天数>=3 AND 统计6日中满足V01ORV02的天数=1 AND 7日内最低价距今天数 = 1 AND 7日内最高价距今天数 >= 6 AND V03
V4赋值: 统计8日中满足V00的天数>=3 AND 统计7日中满足V01ORV02的天数<=2 AND 8日内最低价距今天数 = 2 AND 8日内最高价距今天数 >= 7 AND V04
V5赋值: 统计8日中满足V00的天数>=3 AND 统计7日中满足V01ORV02的天数<=2 AND 8日内最低价距今天数 = 1 AND 8日内最高价距今天数 >= 7 AND V03
V6赋值: 统计9日中满足V00的天数>=3 AND 统计8日中满足V01ORV02的天数<=3 AND 9日内最低价距今天数 = 2 AND 9日内最高价距今天数 >= 8 AND V04
V7赋值: 统计9日中满足V00的天数>=3 AND 统计8日中满足V01ORV02的天数<=3 AND 9日内最低价距今天数 = 1 AND 9日内最高价距今天数 >= 8 AND V03
V8赋值: 统计10日中满足V00的天数>=3 AND 统计9日中满足V01ORV02的天数<=4 AND 10日内最低价距今天数 = 2 AND 10日内最高价距今天数 >= 9 AND V04
V9赋值: 统计10日中满足V00的天数>=3 AND 统计9日中满足V01ORV02的天数<=4 AND 10日内最低价距今天数 = 1 AND 10日内最高价距今天数 >= 9 AND V03
V10赋值: 统计11日中满足V00的天数>=3 AND 统计10日中满足V01ORV02的天数<=5 AND 11日内最低价距今天数 = 2 AND 11日内最高价距今天数 >= 10 AND V04
输出XG:V1 OR V2 OR V3 OR V4 OR V5 OR V6 OR V7 OR V8 OR V9 OR V10